Jude's Blog

Posts Tagged ‘outlook

Field Report: Cant Move/Delete emails with attachments

with one comment

Issue:


Users were complaining that they are unable to delete mails from outlook. The environment was Exchange Server 2010 with SP1. Users were on Outlook 2010. Strangely, the issue was not seen for all the users. However there were multiple complaints from a few users that they are getting an error message while trying to delete old emails.

Upon checking up with the users, here’s what was noticed:

  • While using outlook:
    • User cannot delete email with attachments.
    • User cannot move email with attachments.
    • Upon deleting and moving the below error message is thrown.
    • User can move/delete emails that does not have any attachments.
Some items cannot be deleted. They were either moved or already deleted, or
access was denied.

More Details>>

This error may be the result of trying to delete more than 4,000 messages at 
one time.  Outlook can delete no more than 4,000 messages when it is working 
with a server message store.
To avoid this error, delete fewer than 4,000 messages in a single operation.
It is also possible that you do not have the appropriate permissions to 
delete messages. If you need to delete content from a folder owned by someone 
else, contact the owner of the folder to obtain the necessary permissions, 
or have the owner delete the content for you.

das

Now this was quite strange. After looking up for a bit, I came up with a similar issue. However it was related to Exchange Server 2010 RU6 or SP3 environments. If you have such an environment, you might want to look over here: https://support.microsoft.com/en-us/kb/2822208

In our case, it was Exchange Server 2010 SP1. So it had to do with something else.

Cause:


One gotcha out of the symptoms was that it had to do with something related to attachments. So while going through message sizing parameters for user, rules, database, connectors and Transport Services, it was identified that the there was a change done to the Exchange Transport Settings on the Hub Transport Server.  The Maximum Send/Receive sizes was reduced. And that my friend, was the culprit! Here’s what has happened.

Initially, the Maximum Send/Receive sizes were at 10MB. Life was so good. People could send and receive attachments, they were able to delete, move and so much more. Suddenly the administration decided to reduce the sizes to 3MB. This seemed to be the main cause for our issue. Due to some reason (I’m yet to get deep into what relationship it has) mails that’s got attachments greater than the Maximum Send/Receive size (3MB) are not getting deleted.

Resolution:


  1. Open Exchange Management Console.
  2. Navigate to Organization Configuration, Hub Transport , Global Settings , Transport Settings , General tab.
  3. Change the below values to a reasonable value (in my case it was 10MB, the previous value)
    1. Maximum receive message size (MB)
    2. Maximum send message size (MB)
  4. Restart Microsoft Exchange Transport service.
  5. Ask your users to close Outlook and check if the mail items can be deleted now.

That was it. Things worked and they were able to delete the emails.

Bit more information regarding why this happens, I’ll look into more and post over here.

If you have any inputs do comment over here.

 

Written by judeperera

October 27, 2016 at 11:52 am